The configuration change applied overnight appears to have improved performance. Identifi will continue to monitor as traffic increases throughout the day.
Posted Mar 27, 2026 - 09:21 EDT
Update
The VPN device restart completed last night does not appear to have resolved the intermittent issue. Our next step is to implement a configuration change to the VPN device, which will be service-impacting. We currently plan to perform this change after hours, beginning at 11:00 PM ET (03:00 UTC).
In the meantime, please share the following guidance with any users experiencing intermittent issues:
** If an error occurs while loading an image, please refresh or restart your browser. ** If you are indexing a batch and experiencing latency on a file, please allow additional time for the image to load. ** If attributes are not displaying while indexing a batch, please click back and then forward to reload the screen.
If you are experiencing this issue and have not yet notified our Support team, please email Support@identifi.net so we can log your organization as impacted. This information helps us better understand the scope of the issue and identify patterns as we continue troubleshooting.
We will provide further updates as more information becomes available.
Posted Mar 26, 2026 - 10:39 EDT
Update
Our team continues to monitor and investigate the intermittent issue. As part of our ongoing efforts, we will be performing a reboot of a core VPN device after 11:00 PM ET tonight. This device supports all VPN connections, and we are taking this step to rule out the VPN connection as the root cause. We will provide further updates as more information becomes available.
Posted Mar 25, 2026 - 16:54 EDT
Update
Our team is actively monitoring and investigating this intermittent issue. If you haven't already reached out, please email Support@identifi.net and include details about the specific function and location where you're experiencing the issue — this will help us investigate more effectively.
Barring any new developments, our next update will be posted at 4:00 PM US ET (20:00 UTC).
Posted Mar 25, 2026 - 12:15 EDT
Update
Identifi continues to monitor and investigate this issue. It remains an intermittent condition. Some end users report that closing and restarting the browser can help. If you are experiencing this issue and have not already contacted Support, please email Support@identifi.net so we can further investigate. When you contact Support, please provide detailed information about which function you are using and where you are experiencing an issue.
Unless there is new information sooner, we will post another update at 12:00 PM US ET (16:00 UTC).
Posted Mar 25, 2026 - 09:57 EDT
Update
We have been actively monitoring the situation and working with customers throughout the day; however, a root cause has not yet been identified. If you are experiencing this issue and have not already contacted Support, please email Support@identifi.net so we can further investigate.
At this time, the issue appears to be intermittent and does not impact all users or environments. We will continue to monitor the situation and provide updates as more information becomes available.
Posted Mar 24, 2026 - 16:56 EDT
Update
We are continuing to investigate this issue.
Posted Mar 24, 2026 - 14:35 EDT
Investigating
Identifi is aware of intermittent slow performance. We are actively investigating.